Tronixlabs Support Forum
Sign up Latest Topics
 
 
 


Reply
  Author   Comment  
simpsora

Junior Member
Registered:
Posts: 2
Reply with quote  #1 
Hi,

I bought a couple of TLRELAY1 single-channel relay boards for use with an ESP8266 NodeMCU.  I'm having trouble activating the relay.

I'm powering the board via the USB connector.  3V3 is connected to Vcc on the relay, ground to ground, and pin D1 is connected to In1.  RVcc and Vcc are connected via the jumper. 

When I set D1 low, the LED on the relay comes on, but there's no resistance drop on the NO & common contacts.  There is also a very faint clicking sound coming from the relay when the control pin is low.  This happens to both boards.

I'm toggling the control pin via button press on the ESP2866.  The code prints the pin state every second (plus on press), so I don't think the pin itself is turning on and off rapidly.

The use case for this relay is to connect to the actuator button on a garage door opener, and to close it on command.

Am I doing something wrong?  I'd expect the resistance to drop on the NO contacts when the pin goes low and the LED comes on, but that's not happening.

Thanks!
Ross

tronixlabs

Avatar / Picture

Moderator
Registered:
Posts: 799
Reply with quote  #2 
There is a possibility that the ESP boards cannot provide enough current. 
Try powering the relay board from an external 5V or 3.3V. 

__________________

- Support always available for our products - email support@tronixlabs.com

simpsora

Junior Member
Registered:
Posts: 2
Reply with quote  #3 
Hi,

Thanks for the reply!  I tried that, and have had even less luck.

I tried following the directions to power from an external source on the product page exactly, but nothing changed.  To simplify things, I've removed the microntroller from the mix entirely.  I tried the following with an external power supply (5v 2A):

- Remove the jumper on Vcc+RVcc
- Connect +5v to RVcc
- Connect Gnd to Gnd

Result:
- Measured 5v between RVcc and Gnd
- D1 does not light up
- 0 resistance on NC contacts
- Infinite resistance on NO contacts
- No sound coming from the relay at all

I connected +5v to In1, and nothing happened -- no change to the resistance of the contacts.  I was able to measure 5v between Gnd and In1.

I can't tell what's happening here -- is there something wrong with the relays?  I tested with both and both behave the same way.  Would trying to use them underpowered as I was before cause a problem like this?  Is there anything further I can to do test the relay?

Thanks again,
Ross
Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.